Please check browser settings. It is strongly recommended to get an up-to-date version. You should also check the technical requirements. (Cf. What are the technical requirements?)